phpmyadmin 配置文件权限错误,不应任何用户都能修改!

/ 0评 / 0

解决phpmyadmin配置文件的权限问题

如果部署的phpmyadmin权限为所有人可写,即权限为777,就会报”Wrong permissions on configuration file, should not be world writable!” 这个错误。

可以通过修改文件夹权限解决:
#chmod -R 755 phpmyadmin
(ubuntu)
$sudo chmod -R 755 phpmyadin

也可以通过修改phpmyadmin的配置文件解决:
找到phpmyadmin/libraries/config.default.php文件,
把 $cfg['CheckConfigurationPermissions'] 修改为false。

发表评论

邮箱地址不会被公开。 必填项已用*标注